Find a jobRecruiters

GPON - Staff Test Engineer

Exclusive opportunity

Onsite

GPON - Staff Test Engineer

Qualcomm

GPON - Staff Test Engineer

Skills

PythonLinux

1 month ago

Share this opportunity

Share this opportunity to other talents of your network:
✓ Offer them a visibility boost with clients.
✓ Help your contacts find their next job.

Important information


Contract type:

Permanent

Location:

Chennai, Tamil Nadu, India

Work mode:

Onsite

Published on:

12 September 2026

What they need


Company Qualcomm India Private Limited

Job Area Engineering Group, Engineering Group > Systems Test Engineering

Skills General Summary: TOOLS/Protocols Technologies with sound knowledge

  • GPON/XGS-PON/L2/L3 network protocol Test experience with minimum of 1 to 5 years
  • WLAN Testing (added advantage)
  • Independent Project handling with analytical ability
  • Testing Experience
  • Functional and Performance Experience in Broadband technologies (GPON,XGS-PON,OLT, ONT)
  • L2/L3 network protocol
  • BB247 and TR309 Certification Test experience
  • Have worked on testing of ONT/OLT products.

Protocols/Layers with good theoretical & practical knowledge Sound knowledge on

  • L2/L3 network protocol : TCP/IP, NAT,IGMP, QOS, DHCP, VLAN, PPPoE,
  • PON: GEM Frame, T-CONT,GEM Ports, QoS, GPON, XGSPON
  • WLAN: Basic Knowledge on WLAN
  • Traffic Generators
  • Understating and Usage of Traffic generator tools like Spirent / Ixia / Chariot/ Veriwave. Knowledge on RFC2544, RFC2889, RFC3918 tests etc.
  • Handson experience in configuring different OLT Vendors (Nokia, Huawei, ZTE..)
  • Traffic Analyzers
  • Wireshark, Ethereal, airopeak/omnipeak

Operating Systems

  • Windows 10/XP/Win7, Linux

Automation

  • Scripting Knowledge of Automation Scripts is mandatory – Python / Perl / TCL

Minimum Qualifications

  • Bachelor's degree in Engineering, Information Systems, Computer Science, or related field and 4+ years of Systems Test Engineering or related work experience.

OR

Master's degree in Engineering, Information Systems, Computer Science, or related field and 3+ years of Systems Test Engineering or related work experience.

OR

PhD in Engineering, Information Systems, Computer Science, or related field and 2+ years of Systems Test Engineering or related work experience.

Applicants : Qualcomm is an equal opportunity employer. If you are an individual with a disability and need an accommodation during the application/hiring process, rest assured that Qualcomm is committed to providing an accessible process. You may e-mail [email protected] or call Qualcomm's toll-free number found here. Upon request, Qualcomm will provide reasonable accommodations to support individuals with disabilities to be able participate in the hiring process. Qualcomm is also committed to making our workplace accessible for individuals with disabilities. (Keep in mind that this email address is used to provide reasonable accommodations for individuals with disabilities. We will not respond here to requests for updates on applications or resume inquiries).

Qualcomm expects its employees to abide by all applicable policies and procedures, including but not limited to security and other requirements regarding protection of Company confidential information and other confidential and/or proprietary information, to the extent those requirements are permissible under applicable law.

To all Staffing and Recruiting Agencies : Our Careers Site is only for individuals seeking a job at Qualcomm. Staffing and recruiting agencies and individuals being represented by an agency are not authorized to use this site or to submit profiles, applications or resumes, and any such submissions will be considered unsolicited. Qualcomm does not accept unsolicited resumes or applications from agencies. Please do not forward resumes to our jobs alias, Qualcomm employees or any other company location. Qualcomm is not responsible for any fees related to unsolicited resumes/applications.

If you would like more information about this role, please contact Qualcomm Careers.

Other offers great for you!

These companies are also looking for great profiles

NG Consulting

Ingénieur test hardware

Selon Profil

Permanent contract

Lyon, France

Onsite, Hybrid

Skills

Electronicsautomatismeélectrotechnique

8 months ago

Quick apply

Wikeys

Ingénieur Test Automation Medior

600

Freelance

Brussels, Belgium

Hybrid

Skills

Testing & QAGitPlaywrightJirasoftware testingautomatisation des testsTypeScriptGroovyReadyAPIXRAY

1 month ago

Quick apply

iSupplier

Ingénieur Test Intégration

500

Freelance

78280 Guyancourt, France

Onsite

Skills

XrayJenkins

1 month ago

Quick apply

The best place to find your next move

© 2026. All Rights Reserved.

Talents

Find a job

Create a profile

Solutions and tools